"Object moved to here" Error

Topics: Developer Forum
Jun 2, 2010 at 12:20 PM
Edited Jun 3, 2010 at 7:57 AM


I try to connect from the OperatorConsole (on my local computer) to the Operator web service (it's located on the remote server).

The path to the Web Service is right, but I'm getting this Error Message:

--<html><head><title>Object moved</title></head><body><h2>Object moved to <a href="%2fLiveChat%2fOperator.asmx%3fAspxAutoDetectCookieSupport%3d1">here</a>.</h2></body></html>

Thank you!

Upd: Tried to run the OperatorConsole and the WebService both at the local machine at first, all worked exellent.

Jun 2, 2010 at 4:33 PM

Hi Chucha,

  It look like a config problem where somewhere on you app.config file of the Operator Console the path for your production service is not OK. Make sure to manually check the .config file after you save the path to your web service via the Configure Link Button on the login screen of the operator console.

Let me know if it's not that.



Jun 2, 2010 at 4:40 PM

After looking closely to your moved location, this has to do with session state probably on your web.config of your website. Look on google for "webservice object moved autodetectcookiesupport"


Jun 8, 2010 at 3:22 PM
Edited Jun 8, 2010 at 3:30 PM

Hi dstpierre!

Thank you for your answer. I think all .config are correct.

The path in the OperatorConsole program at configuration fields is right too.

<setting name="OperatorConsole_LiveChatWS_Operator" serializeAs="String">

"mysite" - is my domain.

This is the Request body to Web Service:
<?xml version="1.0" encoding="utf-8"?>
<soap:Envelope xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
        <AuthenticationHeader xmlns="http://www.dominicstpierre.net/LiveChatStarterKit/2007/09">
        <LogIn xmlns="http://www.dominicstpierre.net/LiveChatStarterKit/2007/09">

There are also "SOAPAction: "http://www.dominicstpierre.net/LiveChatStarterKit/2007/09/LogIn"" in the Request header, but the host is mine.

Is that correct?

Google Search results are not helpful yet for me :(

Thank you!